TaeM Framework (net20) Namespaces

Namespaces
Namespace | Description
TaeM.Framework.Data | This namespace contains Database access helper and Database parameter helper classes for each Database about MS-SQL Server, MySQL Server, Oracle Server.
TaeM.Framework.Data.MsSql | This namespace contains some classes for data binding MS-SQL Server's data to user defined entity class.
TaeM.Framework.Data.MySql | This namespace contains some classes for data binding MySQL Database Server's data to user defined entity class.

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


TaeM.Framework.Data Namespace

This namespace contains Database access helper and Database parameter helper classes for each Database about MS-SQL Server, MySQL Server, Oracle Server.
Classes
 | Class | Description
Public class | MsSqlDataHelperFactory | MsSqlDataHelperFactory Class - Implement data access helper of MS-SQL Server
Public class | MsSqlParameterHelperFactory | MsSqlParameterHelperFactory class - Implement parameter helper of MS-SQL Server
Public class | MySqlDataHelperFactory | MySqlDataHelperFactory Class - Implement data access helper of MySQL DB
Public class | MySqlParameterHelperFactory | MySqlParameterHelperFactory class - Implement parameter helper of MySql DB

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MsSqlDataHelperFactory Class

MsSqlDataHelperFactory Class - Implement data access helper of MS-SQL Server
Inheritance Hierarchy
SystemObject
TaeM.Framework.DataMsSqlDataHelperFactory

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static class MsSqlDataHelperFactory
Public NotInheritable Class MsSqlDataHelperFactory
public ref class MsSqlDataHelperFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MsSqlDataHelperFactory =  class end
The MsSqlDataHelperFactory type exposes the following members.
  Methods
Name | Description
Execute | Execute method - Execute query and return the number of affected row from the SQL query execution result with an SQL command type, an SQL query, and SQL parameters
SelectMultipleEntitiesT | SelectMultipleEntities<T> method - Execute query and return their multiple rows result with a type of return object, an SQL command type, an SQL query, and SQL parameters
SelectScalar | SelectScalar method - Execute query and return the value of first row and first column with an SQL command type, an SQL query, and SQL parameters
SelectSingleEntityT | SelectSingleEntity<T> method - Execute query and return their single row result with a type of return object, an SQL command type, an SQL query, and SQL parameters
Top
  See Also
Reference
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlDataHelperFactory Methods

The MsSqlDataHelperFactory type exposes the following members.

Methods
Name | Description
Execute | Execute method - Execute query and return the number of affected row from the SQL query execution result with an SQL command type, an SQL query, and SQL parameters
SelectMultipleEntitiesT | SelectMultipleEntities<T> method - Execute query and return their multiple rows result with a type of return object, an SQL command type, an SQL query, and SQL parameters
SelectScalar | SelectScalar method - Execute query and return the value of first row and first column with an SQL command type, an SQL query, and SQL parameters
SelectSingleEntityT | SelectSingleEntity<T> method - Execute query and return their single row result with a type of return object, an SQL command type, an SQL query, and SQL parameters
Top
See Also

Reference

MsSqlDataHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MsSqlDataHelperFactory.Execute Method

TaeM Framework (net20)

MsSqlDataHelperFactoryExecute Method

Execute method - Execute query and return the number of affected row from the SQL query execution result with an SQL command type, an SQL query, and SQL parameters

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static int Execute(
    DbConnection connection,
    CommandType cmdType,
    string query,
    params DbParameter[] dbParams
)
Public Shared Function Execute (
    connection As DbConnection,
    cmdType As CommandType,
    query As String,
    ParamArray dbParams As DbParameter()
) As Integer
public:
static int Execute(
    DbConnection^ connection,
    CommandType cmdType,
    String^ query,
    ... array<DbParameter^>^ dbParams
)
static member Execute :
        connection : DbConnection *
        cmdType : CommandType *
        query : string *
        dbParams : DbParameter[] -> int

Parameters
connection
Type: System.Data.CommonDbConnection
MS-SQL connection object
cmdType
Type: System.DataCommandType
an SQL command type
query
Type: SystemString
an SQL query
dbParams
Type: System.Data.CommonDbParameter
SQL parameters
Return Value
Type: Int32
The number of affected row from the SQL execution result
  See Also
Reference
MsSqlDataHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlDataHelperFactory.SelectMultipleEntities(T) Method

MsSqlDataHelperFactorySelectMultipleEntitiesT Method

SelectMultipleEntities<T> method - Execute query and return their multiple rows result with a type of return object, an SQL command type, an SQL query, and SQL parameters

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static List<T> SelectMultipleEntities<T>(
    DbConnection connection,
    Type type,
    CommandType cmdType,
    string query,
    params DbParameter[] dbParams
)

Public Shared Function SelectMultipleEntities(Of T) (
    connection As DbConnection,
    type As Type,
    cmdType As CommandType,
    query As String,
    ParamArray dbParams As DbParameter()
) As List(Of T)
public:
generic<typename T>
static List<T>^ SelectMultipleEntities(
    DbConnection^ connection,
    Type^ type,
    CommandType cmdType,
    String^ query,
    ... array<DbParameter^>^ dbParams
)
static member SelectMultipleEntities :
        connection : DbConnection *
        type : Type *
        cmdType : CommandType *
        query : string *
        dbParams : DbParameter[] -> List<'T>

Parameters
connection
Type: System.Data.CommonDbConnection
MS-SQL connection object
type
Type: SystemType
a type of return object data
cmdType
Type: System.DataCommandType
an SQL command type
query
Type: SystemString
an SQL query
dbParams
Type: System.Data.CommonDbParameter
SQL parameters
Type Parameters
T
a type of return object data
Return Value
Type: List T
List of object that have the results of SQL execution
  See Also
Reference
MsSqlDataHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlDataHelperFactory.SelectScalar Method

MsSqlDataHelperFactorySelectScalar Method

SelectScalar method - Execute query and return the value of first row and first column with an SQL command type, an SQL query, and SQL parameters

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static Object SelectScalar(
    DbConnection connection,
    CommandType cmdType,
    string query,
    params DbParameter[] dbParams
)
Public Shared Function SelectScalar (
    connection As DbConnection,
    cmdType As CommandType,
    query As String,
    ParamArray dbParams As DbParameter()
) As Object
public:
static Object^ SelectScalar(
    DbConnection^ connection,
    CommandType cmdType,
    String^ query,
    ... array<DbParameter^>^ dbParams
)
static member SelectScalar :
        connection : DbConnection *
        cmdType : CommandType *
        query : string *
        dbParams : DbParameter[] -> Object

Parameters
connection
Type: System.Data.CommonDbConnection
MS-SQL connection object
cmdType
Type: System.DataCommandType
an SQL command type
query
Type: SystemString
an SQL query
dbParams
Type: System.Data.CommonDbParameter
SQL parameters
Return Value
Type: Object
The value of first row and first column in the SQL execution result
  See Also
Reference
MsSqlDataHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlDataHelperFactory.SelectSingleEntity(T) Method

MsSqlDataHelperFactorySelectSingleEntityT Method

SelectSingleEntity<T> method - Execute query and return their single row result with a type of return object, an SQL command type, an SQL query, and SQL parameters

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static T SelectSingleEntity<T>(
    DbConnection connection,
    Type type,
    CommandType cmdType,
    string query,
    params DbParameter[] dbParams
)

Public Shared Function SelectSingleEntity(Of T) (
    connection As DbConnection,
    type As Type,
    cmdType As CommandType,
    query As String,
    ParamArray dbParams As DbParameter()
) As T
public:
generic<typename T>
static T SelectSingleEntity(
    DbConnection^ connection,
    Type^ type,
    CommandType cmdType,
    String^ query,
    ... array<DbParameter^>^ dbParams
)
static member SelectSingleEntity :
        connection : DbConnection *
        type : Type *
        cmdType : CommandType *
        query : string *
        dbParams : DbParameter[] -> 'T

Parameters
connection
Type: System.Data.CommonDbConnection
MS-SQL connection object
type
Type: SystemType
a type of return object data
cmdType
Type: System.DataCommandType
an SQL command type
query
Type: SystemString
an SQL query
dbParams
Type: System.Data.CommonDbParameter
SQL parameters
Type Parameters
T
a type of return object data
Return Value
Type: T
an object that has the result of SQL execution
  See Also
Reference
MsSqlDataHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlParameterHelperFactory Class

MsSqlParameterHelperFactory class - Implement parameter helper of MS-SQL Server
Inheritance Hierarchy
SystemObject
TaeM.Framework.DataMsSqlParameterHelperFactory

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static class MsSqlParameterHelperFactory
Public NotInheritable Class MsSqlParameterHelperFactory
public ref class MsSqlParameterHelperFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MsSqlParameterHelperFactory =  class end
The MsSqlParameterHelperFactory type exposes the following members.
  Properties
Name | Description
ProviderName | ProviderName property - Get or Set Database Provider Name
Top
  Methods
Name | Description
CreateParameter(String, String, Object, ParameterDirection) | CreateParameter method - Create and return an object of MS-SQL Server Parameter with provider name, parameter name, value, direction of parameter.
CreateParameterT(String, String, Object, T, ParameterDirection) | CreateParameter<T> method - Create and return an object of MS-SQL Server Parameter with provider name, parameter name, DB Type enum(System.Data.DbType or SqlDbType), value, direction of parameter.
CreateParameterWOProviderName(String, Object, ParameterDirection) | CreateParameterWOProviderName method - If you set the ProviderName, you can create and return an object of MS-SQL Server Parameter with parameter name, value, direction of parameter.
CreateParameterWOProviderNameT(String, Object, T, ParameterDirection) | CreateParameterWOProviderName<T> method - If you set the ProviderName, you can create and return an object of MS-SQL Server Parameter with parameter name, DB Type enum(System.Data.DbType or SqlDbType), value, direction of parameter.
Top
  See Also
Reference
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlParameterHelperFactory Properties

The MsSqlParameterHelperFactory type exposes the following members.

Properties
Name | Description
ProviderName | ProviderName property - Get or Set Database Provider Name
Top
See Also

Reference

MsSqlParameterHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MsSqlParameterHelperFactory.ProviderName Property

MsSqlParameterHelperFactoryProviderName Property

ProviderName property - Get or Set Database Provider Name

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static string ProviderName { get; set; }
Public Shared Property ProviderName As String
    Get
    Set
public:
static property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
static member ProviderName : string with get, set

Property Value
Type: String
  See Also
Reference
MsSqlParameterHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlParameterHelperFactory Methods

Methods
Name | Description
CreateParameter(String, String, Object, ParameterDirection) | CreateParameter method - Create and return an object of MS-SQL Server Parameter with provider name, parameter name, value, direction of parameter.
CreateParameterT(String, String, Object, T, ParameterDirection) | CreateParameter<T> method - Create and return an object of MS-SQL Server Parameter with provider name, parameter name, DB Type enum(System.Data.DbType or SqlDbType), value, direction of parameter.
CreateParameterWOProviderName(String, Object, ParameterDirection) | CreateParameterWOProviderName method - If you set the ProviderName, you can create and return an object of MS-SQL Server Parameter with parameter name, value, direction of parameter.
CreateParameterWOProviderNameT(String, Object, T, ParameterDirection) | CreateParameterWOProviderName<T> method - If you set the ProviderName, you can create and return an object of MS-SQL Server Parameter with parameter name, DB Type enum(System.Data.DbType or SqlDbType), value, direction of parameter.
Top
See Also

Reference

MsSqlParameterHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MsSqlParameterHelperFactory.CreateParameter Method

MsSqlParameterHelperFactoryCreateParameter Method

Overload List
Name | Description
CreateParameter(String, String, Object, ParameterDirection) | CreateParameter method - Create and return an object of MS-SQL Server Parameter with provider name, parameter name, value, direction of parameter.
CreateParameterT(String, String, Object, T, ParameterDirection) | CreateParameter<T> method - Create and return an object of MS-SQL Server Parameter with provider name, parameter name, DB Type enum(System.Data.DbType or SqlDbType), value, direction of parameter.
Top
See Also

Reference

MsSqlParameterHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MsSqlParameterHelperFactory.CreateParameter Method (String, String, Object, ParameterDirection)

MsSqlParameterHelperFactoryCreateParameter Method (String, String, Object, ParameterDirection)

CreateParameter method - Create and return an object of MS-SQL Server Parameter with provider name, parameter name, value, direction of parameter.

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static DbParameter CreateParameter(
    string providerName,
    string parameterName,
    Object value,
    ParameterDirection direction
)
Public Shared Function CreateParameter (
    providerName As String,
    parameterName As String,
    value As Object,
    direction As ParameterDirection
) As DbParameter
public:
static DbParameter^ CreateParameter(
    String^ providerName,
    String^ parameterName,
    Object^ value,
    ParameterDirection direction
)
static member CreateParameter :
        providerName : string *
        parameterName : string *
        value : Object *
        direction : ParameterDirection -> DbParameter

Parameters
providerName
Type: SystemString
a name of DB provider
parameterName
Type: SystemString
a name of parameter
value
Type: SystemObject
a value of parameter
direction
Type: System.DataParameterDirection
a directon(Input, InputOutput, Output, or ReturnValue) of parameter
Return Value
Type: DbParameter
an object of MS-SQL Server parameter
  See Also
Reference
MsSqlParameterHelperFactory Class
CreateParameter Overload
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlParameterHelperFactory.CreateParameter(T) Method (String, String, Object, T, ParameterDirection)

MsSqlParameterHelperFactoryCreateParameterT Method (String, String, Object, T, ParameterDirection)

CreateParameter<T> method - Create and return an object of MS-SQL Server Parameter with provider name, parameter name, DB Type enum(System.Data.DbType or SqlDbType), value, direction of parameter.

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static DbParameter CreateParameter<T>(
    string providerName,
    string parameterName,
    Object value,
    T dbType,
    ParameterDirection direction
)

Public Shared Function CreateParameter(Of T) (
    providerName As String,
    parameterName As String,
    value As Object,
    dbType As T,
    direction As ParameterDirection
) As DbParameter
public:
generic<typename T>
static DbParameter^ CreateParameter(
    String^ providerName,
    String^ parameterName,
    Object^ value,
    T dbType,
    ParameterDirection direction
)
static member CreateParameter :
        providerName : string *
        parameterName : string *
        value : Object *
        dbType : 'T *
        direction : ParameterDirection -> DbParameter

Parameters
providerName
Type: SystemString
a name of DB provider
parameterName
Type: SystemString
a name of parameter
value
Type: SystemObject
a value of parameter
dbType
Type: T
a data type of parameter (DB Type enum like System.Data.DbType or SqlDbType)
direction
Type: System.DataParameterDirection
a directon(Input, InputOutput, Output, or ReturnValue) of parameter
Type Parameters
T
a type of DB Type enum(System.Data.DbType or SqlDbType)
Return Value
Type: DbParameter
an object of MS-SQL Server parameter
  See Also
Reference
MsSqlParameterHelperFactory Class
CreateParameter Overload
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlParameterHelperFactory.CreateParameterWOProviderName Method

MsSqlParameterHelperFactoryCreateParameterWOProviderName Method

Overload List
Name | Description
CreateParameterWOProviderName(String, Object, ParameterDirection) | CreateParameterWOProviderName method - If you set the ProviderName, you can create and return an object of MS-SQL Server Parameter with parameter name, value, direction of parameter.
CreateParameterWOProviderNameT(String, Object, T, ParameterDirection) | CreateParameterWOProviderName<T> method - If you set the ProviderName, you can create and return an object of MS-SQL Server Parameter with parameter name, DB Type enum(System.Data.DbType or SqlDbType), value, direction of parameter.
Top
See Also

Reference

MsSqlParameterHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MsSqlParameterHelperFactory.CreateParameterWOProviderName Method (String, Object, ParameterDirection)

MsSqlParameterHelperFactoryCreateParameterWOProviderName Method (String, Object, ParameterDirection)

CreateParameterWOProviderName method - If you set the ProviderName, you can create and return an object of MS-SQL Server Parameter with parameter name, value, direction of parameter.

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static DbParameter CreateParameterWOProviderName(
    string parameterName,
    Object value,
    ParameterDirection direction
)
Public Shared Function CreateParameterWOProviderName (
    parameterName As String,
    value As Object,
    direction As ParameterDirection
) As DbParameter
public:
static DbParameter^ CreateParameterWOProviderName(
    String^ parameterName,
    Object^ value,
    ParameterDirection direction
)
static member CreateParameterWOProviderName :
        parameterName : string *
        value : Object *
        direction : ParameterDirection -> DbParameter

Parameters
parameterName
Type: SystemString
a name of parameter
value
Type: SystemObject
a value of parameter
direction
Type: System.DataParameterDirection
a directon(Input, InputOutput, Output, or ReturnValue) of parameter
Return Value
Type: DbParameter
an object of MS-SQL Server parameter
  See Also
Reference
MsSqlParameterHelperFactory Class
CreateParameterWOProviderName Overload
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlParameterHelperFactory.CreateParameterWOProviderName(T) Method (String, Object, T, ParameterDirection)

MsSqlParameterHelperFactoryCreateParameterWOProviderNameT Method (String, Object, T, ParameterDirection)

CreateParameterWOProviderName<T> method - If you set the ProviderName, you can create and return an object of MS-SQL Server Parameter with parameter name, DB Type enum(System.Data.DbType or SqlDbType), value, direction of parameter.

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static DbParameter CreateParameterWOProviderName<T>(
    string parameterName,
    Object value,
    T dbType,
    ParameterDirection direction
)

Public Shared Function CreateParameterWOProviderName(Of T) (
    parameterName As String,
    value As Object,
    dbType As T,
    direction As ParameterDirection
) As DbParameter
public:
generic<typename T>
static DbParameter^ CreateParameterWOProviderName(
    String^ parameterName,
    Object^ value,
    T dbType,
    ParameterDirection direction
)
static member CreateParameterWOProviderName :
        parameterName : string *
        value : Object *
        dbType : 'T *
        direction : ParameterDirection -> DbParameter

Parameters
parameterName
Type: SystemString
a name of parameter
value
Type: SystemObject
a value of parameter
dbType
Type: T
a data type of parameter (DB Type enum like System.Data.DbType or SqlDbType)
direction
Type: System.DataParameterDirection
a directon(Input, InputOutput, Output, or ReturnValue) of parameter
Type Parameters
T
a type of DB Type enum(System.Data.DbType or SqlDbType)
Return Value
Type: DbParameter
an object of MS-SQL Server parameter
  See Also
Reference
MsSqlParameterHelperFactory Class
CreateParameterWOProviderName Overload
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlDataHelperFactory Class

MySqlDataHelperFactory Class - Implement data access helper of MySQL DB
Inheritance Hierarchy
SystemObject
TaeM.Framework.DataMySqlDataHelperFactory

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static class MySqlDataHelperFactory
Public NotInheritable Class MySqlDataHelperFactory
public ref class MySqlDataHelperFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MySqlDataHelperFactory =  class end
The MySqlDataHelperFactory type exposes the following members.
  Methods
Name | Description
Execute | Execute method - Execute query and return the number of affected row from the SQL query execution result with an SQL command type, an SQL query, and SQL parameters
SelectMultipleEntitiesT | SelectMultipleEntities<T> method - Execute query and return their multiple rows result with a type of return object, an SQL command type, an SQL query, and SQL parameters
SelectScalar | SelectScalar method - Execute query and return the value of first row and first column with an SQL command type, an SQL query, and SQL parameters
SelectSingleEntityT | SelectSingleEntity<T> method - Execute query and return their single row result with a type of return object, an SQL command type, an SQL query, and SQL parameters
Top
  See Also
Reference
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlDataHelperFactory Methods

The MySqlDataHelperFactory type exposes the following members.

Methods
Name | Description
Execute | Execute method - Execute query and return the number of affected row from the SQL query execution result with an SQL command type, an SQL query, and SQL parameters
SelectMultipleEntitiesT | SelectMultipleEntities<T> method - Execute query and return their multiple rows result with a type of return object, an SQL command type, an SQL query, and SQL parameters
SelectScalar | SelectScalar method - Execute query and return the value of first row and first column with an SQL command type, an SQL query, and SQL parameters
SelectSingleEntityT | SelectSingleEntity<T> method - Execute query and return their single row result with a type of return object, an SQL command type, an SQL query, and SQL parameters
Top
See Also

Reference

MySqlDataHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MySqlDataHelperFactory.Execute Method

MySqlDataHelperFactoryExecute Method

Execute method - Execute query and return the number of affected row from the SQL query execution result with an SQL command type, an SQL query, and SQL parameters

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static int Execute(
    DbConnection connection,
    CommandType cmdType,
    string query,
    params DbParameter[] dbParams
)
Public Shared Function Execute (
    connection As DbConnection,
    cmdType As CommandType,
    query As String,
    ParamArray dbParams As DbParameter()
) As Integer
public:
static int Execute(
    DbConnection^ connection,
    CommandType cmdType,
    String^ query,
    ... array<DbParameter^>^ dbParams
)
static member Execute :
        connection : DbConnection *
        cmdType : CommandType *
        query : string *
        dbParams : DbParameter[] -> int

Parameters
connection
Type: System.Data.CommonDbConnection
MySQL connection object
cmdType
Type: System.DataCommandType
an SQL command type
query
Type: SystemString
an SQL query
dbParams
Type: System.Data.CommonDbParameter
SQL parameters
Return Value
Type: Int32
The number of affected row from the SQL execution result
  See Also
Reference
MySqlDataHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlDataHelperFactory.SelectMultipleEntities(T) Method

MySqlDataHelperFactorySelectMultipleEntitiesT Method

SelectMultipleEntities<T> method - Execute query and return their multiple rows result with a type of return object, an SQL command type, an SQL query, and SQL parameters

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static List<T> SelectMultipleEntities<T>(
    DbConnection connection,
    Type type,
    CommandType cmdType,
    string query,
    params DbParameter[] dbParams
)

Public Shared Function SelectMultipleEntities(Of T) (
    connection As DbConnection,
    type As Type,
    cmdType As CommandType,
    query As String,
    ParamArray dbParams As DbParameter()
) As List(Of T)
public:
generic<typename T>
static List<T>^ SelectMultipleEntities(
    DbConnection^ connection,
    Type^ type,
    CommandType cmdType,
    String^ query,
    ... array<DbParameter^>^ dbParams
)
static member SelectMultipleEntities :
        connection : DbConnection *
        type : Type *
        cmdType : CommandType *
        query : string *
        dbParams : DbParameter[] -> List<'T>

Parameters
connection
Type: System.Data.CommonDbConnection
MySQL connection object
type
Type: SystemType
a type of return object data
cmdType
Type: System.DataCommandType
an SQL command type
query
Type: SystemString
an SQL query
dbParams
Type: System.Data.CommonDbParameter
SQL parameters
Type Parameters
T
a type of return object data
Return Value
Type: List T
List of object that have the results of SQL execution
  See Also
Reference
MySqlDataHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlDataHelperFactory.SelectScalar Method

MySqlDataHelperFactorySelectScalar Method

SelectScalar method - Execute query and return the value of first row and first column with an SQL command type, an SQL query, and SQL parameters

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static Object SelectScalar(
    DbConnection connection,
    CommandType cmdType,
    string query,
    params DbParameter[] dbParams
)
Public Shared Function SelectScalar (
    connection As DbConnection,
    cmdType As CommandType,
    query As String,
    ParamArray dbParams As DbParameter()
) As Object
public:
static Object^ SelectScalar(
    DbConnection^ connection,
    CommandType cmdType,
    String^ query,
    ... array<DbParameter^>^ dbParams
)
static member SelectScalar :
        connection : DbConnection *
        cmdType : CommandType *
        query : string *
        dbParams : DbParameter[] -> Object

Parameters
connection
Type: System.Data.CommonDbConnection
MySQL connection object
cmdType
Type: System.DataCommandType
an SQL command type
query
Type: SystemString
an SQL query
dbParams
Type: System.Data.CommonDbParameter
SQL parameters
Return Value
Type: Object
The value of first row and first column in the SQL execution result
  See Also
Reference
MySqlDataHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlDataHelperFactory.SelectSingleEntity(T) Method

MySqlDataHelperFactorySelectSingleEntityT Method

SelectSingleEntity<T> method - Execute query and return their single row result with a type of return object, an SQL command type, an SQL query, and SQL parameters

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static T SelectSingleEntity<T>(
    DbConnection connection,
    Type type,
    CommandType cmdType,
    string query,
    params DbParameter[] dbParams
)

Public Shared Function SelectSingleEntity(Of T) (
    connection As DbConnection,
    type As Type,
    cmdType As CommandType,
    query As String,
    ParamArray dbParams As DbParameter()
) As T
public:
generic<typename T>
static T SelectSingleEntity(
    DbConnection^ connection,
    Type^ type,
    CommandType cmdType,
    String^ query,
    ... array<DbParameter^>^ dbParams
)
static member SelectSingleEntity :
        connection : DbConnection *
        type : Type *
        cmdType : CommandType *
        query : string *
        dbParams : DbParameter[] -> 'T

Parameters
connection
Type: System.Data.CommonDbConnection
MySQL connection object
type
Type: SystemType
a type of return object data
cmdType
Type: System.DataCommandType
an SQL command type
query
Type: SystemString
an SQL query
dbParams
Type: System.Data.CommonDbParameter
SQL parameters
Type Parameters
T
a type of return object data
Return Value
Type: T
an object that has the result of SQL execution
  See Also
Reference
MySqlDataHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlParameterHelperFactory Class

MySqlParameterHelperFactory class - Implement parameter helper of MySql DB
Inheritance Hierarchy
SystemObject
TaeM.Framework.DataMySqlParameterHelperFactory

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static class MySqlParameterHelperFactory
Public NotInheritable Class MySqlParameterHelperFactory
public ref class MySqlParameterHelperFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MySqlParameterHelperFactory =  class end
The MySqlParameterHelperFactory type exposes the following members.
  Properties
Name | Description
ProviderName | ProviderName property - Get or Set Database Provider Name
Top
  Methods
Name | Description
CreateParameter(String, String, Object, ParameterDirection) | CreateParameter method - Create and return an object of MySQL DB Parameter with provider name, parameter name, value, direction of parameter.
CreateParameterT(String, String, Object, T, ParameterDirection) | CreateParameter<T> method - Create and return an object of MySQL DB Parameter with provider name, parameter name, DB Type enum(System.Data.DbType or MySqlDbType), value, direction of parameter.
CreateParameterWOProviderName(String, Object, ParameterDirection) | CreateParameterWOProviderName method - If you set the ProviderName, you can create and return an object of MySQL DB Parameter with parameter name, value, direction of parameter.
CreateParameterWOProviderNameT(String, Object, T, ParameterDirection) | CreateParameterWOProviderName<T> method - If you set the ProviderName, you can create and return an object of MySQL DB Parameter with parameter name, DB Type enum(System.Data.DbType or MySqlDbType), value, direction of parameter.
Top
  See Also
Reference
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlParameterHelperFactory Properties

The MySqlParameterHelperFactory type exposes the following members.

Properties
Name | Description
ProviderName | ProviderName property - Get or Set Database Provider Name
Top
See Also

Reference

MySqlParameterHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MySqlParameterHelperFactory.ProviderName Property

MySqlParameterHelperFactoryProviderName Property

ProviderName property - Get or Set Database Provider Name

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static string ProviderName { get; set; }
Public Shared Property ProviderName As String
    Get
    Set
public:
static property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
static member ProviderName : string with get, set

Property Value
Type: String
  See Also
Reference
MySqlParameterHelperFactory Class
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlParameterHelperFactory Methods

Methods
Name | Description
CreateParameter(String, String, Object, ParameterDirection) | CreateParameter method - Create and return an object of MySQL DB Parameter with provider name, parameter name, value, direction of parameter.
CreateParameterT(String, String, Object, T, ParameterDirection) | CreateParameter<T> method - Create and return an object of MySQL DB Parameter with provider name, parameter name, DB Type enum(System.Data.DbType or MySqlDbType), value, direction of parameter.
CreateParameterWOProviderName(String, Object, ParameterDirection) | CreateParameterWOProviderName method - If you set the ProviderName, you can create and return an object of MySQL DB Parameter with parameter name, value, direction of parameter.
CreateParameterWOProviderNameT(String, Object, T, ParameterDirection) | CreateParameterWOProviderName<T> method - If you set the ProviderName, you can create and return an object of MySQL DB Parameter with parameter name, DB Type enum(System.Data.DbType or MySqlDbType), value, direction of parameter.
Top
See Also

Reference

MySqlParameterHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MySqlParameterHelperFactory.CreateParameter Method

MySqlParameterHelperFactoryCreateParameter Method

Overload List
Name | Description
CreateParameter(String, String, Object, ParameterDirection) | CreateParameter method - Create and return an object of MySQL DB Parameter with provider name, parameter name, value, direction of parameter.
CreateParameterT(String, String, Object, T, ParameterDirection) | CreateParameter<T> method - Create and return an object of MySQL DB Parameter with provider name, parameter name, DB Type enum(System.Data.DbType or MySqlDbType), value, direction of parameter.
Top
See Also

Reference

MySqlParameterHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MySqlParameterHelperFactory.CreateParameter Method (String, String, Object, ParameterDirection)

MySqlParameterHelperFactoryCreateParameter Method (String, String, Object, ParameterDirection)

CreateParameter method - Create and return an object of MySQL DB Parameter with provider name, parameter name, value, direction of parameter.

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static DbParameter CreateParameter(
    string providerName,
    string parameterName,
    Object value,
    ParameterDirection direction
)
Public Shared Function CreateParameter (
    providerName As String,
    parameterName As String,
    value As Object,
    direction As ParameterDirection
) As DbParameter
public:
static DbParameter^ CreateParameter(
    String^ providerName,
    String^ parameterName,
    Object^ value,
    ParameterDirection direction
)
static member CreateParameter :
        providerName : string *
        parameterName : string *
        value : Object *
        direction : ParameterDirection -> DbParameter

Parameters
providerName
Type: SystemString
a name of DB provider
parameterName
Type: SystemString
a name of parameter
value
Type: SystemObject
a value of parameter
direction
Type: System.DataParameterDirection
a directon(Input, InputOutput, Output, or ReturnValue) of parameter
Return Value
Type: DbParameter
an object of MySQL DB parameter
  See Also
Reference
MySqlParameterHelperFactory Class
CreateParameter Overload
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlParameterHelperFactory.CreateParameter(T) Method (String, String, Object, T, ParameterDirection)

MySqlParameterHelperFactoryCreateParameterT Method (String, String, Object, T, ParameterDirection)

CreateParameter<T> method - Create and return an object of MySQL DB Parameter with provider name, parameter name, DB Type enum(System.Data.DbType or MySqlDbType), value, direction of parameter.

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static DbParameter CreateParameter<T>(
    string providerName,
    string parameterName,
    Object value,
    T dbType,
    ParameterDirection direction
)

Public Shared Function CreateParameter(Of T) (
    providerName As String,
    parameterName As String,
    value As Object,
    dbType As T,
    direction As ParameterDirection
) As DbParameter
public:
generic<typename T>
static DbParameter^ CreateParameter(
    String^ providerName,
    String^ parameterName,
    Object^ value,
    T dbType,
    ParameterDirection direction
)
static member CreateParameter :
        providerName : string *
        parameterName : string *
        value : Object *
        dbType : 'T *
        direction : ParameterDirection -> DbParameter

Parameters
providerName
Type: SystemString
a name of DB provider
parameterName
Type: SystemString
a name of parameter
value
Type: SystemObject
a value of parameter
dbType
Type: T
a data type of parameter (DB Type enum like System.Data.DbType or MySqlDbType)
direction
Type: System.DataParameterDirection
a directon(Input, InputOutput, Output, or ReturnValue) of parameter
Type Parameters
T
a type of DB Type enum(System.Data.DbType or MySqlDbType)
Return Value
Type: DbParameter
an object of MySQL DB parameter
  See Also
Reference
MySqlParameterHelperFactory Class
CreateParameter Overload
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlParameterHelperFactory.CreateParameterWOProviderName Method

MySqlParameterHelperFactoryCreateParameterWOProviderName Method

Overload List
Name | Description
CreateParameterWOProviderName(String, Object, ParameterDirection) | CreateParameterWOProviderName method - If you set the ProviderName, you can create and return an object of MySQL DB Parameter with parameter name, value, direction of parameter.
CreateParameterWOProviderNameT(String, Object, T, ParameterDirection) | CreateParameterWOProviderName<T> method - If you set the ProviderName, you can create and return an object of MySQL DB Parameter with parameter name, DB Type enum(System.Data.DbType or MySqlDbType), value, direction of parameter.
Top
See Also

Reference

MySqlParameterHelperFactory Class
TaeM.Framework.Data Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MySqlParameterHelperFactory.CreateParameterWOProviderName Method (String, Object, ParameterDirection)

MySqlParameterHelperFactoryCreateParameterWOProviderName Method (String, Object, ParameterDirection)

CreateParameterWOProviderName method - If you set the ProviderName, you can create and return an object of MySQL DB Parameter with parameter name, value, direction of parameter.

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static DbParameter CreateParameterWOProviderName(
    string parameterName,
    Object value,
    ParameterDirection direction
)
Public Shared Function CreateParameterWOProviderName (
    parameterName As String,
    value As Object,
    direction As ParameterDirection
) As DbParameter
public:
static DbParameter^ CreateParameterWOProviderName(
    String^ parameterName,
    Object^ value,
    ParameterDirection direction
)
static member CreateParameterWOProviderName :
        parameterName : string *
        value : Object *
        direction : ParameterDirection -> DbParameter

Parameters
parameterName
Type: SystemString
a name of parameter
value
Type: SystemObject
a value of parameter
direction
Type: System.DataParameterDirection
a directon(Input, InputOutput, Output, or ReturnValue) of parameter
Return Value
Type: DbParameter
an object of MySQL DB parameter
  See Also
Reference
MySqlParameterHelperFactory Class
CreateParameterWOProviderName Overload
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlParameterHelperFactory.CreateParameterWOProviderName(T) Method (String, Object, T, ParameterDirection)

MySqlParameterHelperFactoryCreateParameterWOProviderNameT Method (String, Object, T, ParameterDirection)

CreateParameterWOProviderName<T> method - If you set the ProviderName, you can create and return an object of MySQL DB Parameter with parameter name, DB Type enum(System.Data.DbType or MySqlDbType), value, direction of parameter.

Namespace: TaeM.Framework.Data
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public static DbParameter CreateParameterWOProviderName<T>(
    string parameterName,
    Object value,
    T dbType,
    ParameterDirection direction
)

Public Shared Function CreateParameterWOProviderName(Of T) (
    parameterName As String,
    value As Object,
    dbType As T,
    direction As ParameterDirection
) As DbParameter
public:
generic<typename T>
static DbParameter^ CreateParameterWOProviderName(
    String^ parameterName,
    Object^ value,
    T dbType,
    ParameterDirection direction
)
static member CreateParameterWOProviderName :
        parameterName : string *
        value : Object *
        dbType : 'T *
        direction : ParameterDirection -> DbParameter

Parameters
parameterName
Type: SystemString
a name of parameter
value
Type: SystemObject
a value of parameter
dbType
Type: T
a data type of parameter (DB Type enum like System.Data.DbType or MySqlDbType)
direction
Type: System.DataParameterDirection
a directon(Input, InputOutput, Output, or ReturnValue) of parameter
Type Parameters
T
a type of DB Type enum(System.Data.DbType or MySqlDbType)
Return Value
Type: DbParameter
an object of MySQL DB parameter
  See Also
Reference
MySqlParameterHelperFactory Class
CreateParameterWOProviderName Overload
TaeM.Framework.Data Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


TaeM.Framework.Data.MsSql Namespace

This namespace contains some classes for data binding MS-SQL Server's data to user defined entity class.
Classes
 | Class | Description
Public class | MsSqlDataBinderAttribute | MsSqlDataBinderAttribute class - Implements data binder attribute in entity class for MS-SQL Server

Send comments on this topic to mail@taemcorp.com


MsSqlDataBinderAttribute Class

MsSqlDataBinderAttribute class - Implements data binder attribute in entity class for MS-SQL Server
Inheritance Hierarchy
SystemObject
SystemAttribute
TaeM.Framework.Data.MsSqlMsSqlDataBinderAttribute

Namespace: TaeM.Framework.Data.MsSql
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
[AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)]
public class MsSqlDataBinderAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field)>
Public Class MsSqlDataBinderAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Property|AttributeTargets::Field)]
public ref class MsSqlDataBinderAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)>]
type MsSqlDataBinderAttribute =
    class
        inherit Attribute
    end
The MsSqlDataBinderAttribute type exposes the following members.
  Constructors
 | Name | Description
Public method | MsSqlDataBinderAttribute | Constructor of MsSqlDataBinderAttribute
Top
  Properties
 | Name | Description
Public property | FieldName | FieldName Property - Field name of MS-SQL Server table or procedure execution result. Therefore, the data of the field specified here is bound to a property or a variable of a specific class specified as an Attribute.
Top
  Methods
 | Name | Description
Public method | CreateDataBinderAttribute | CreateDataBinderAttribute method - Implements data binder attribute string for setting data from MS-SQL Server
Top
  See Also
Reference
TaeM.Framework.Data.MsSql Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlDataBinderAttribute Constructor

Constructor of MsSqlDataBinderAttribute

Namespace: TaeM.Framework.Data.MsSql
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public MsSqlDataBinderAttribute(
    string fieldName
)
Public Sub New (
    fieldName As String
)
public:
MsSqlDataBinderAttribute(
    String^ fieldName
)
new :
        fieldName : string -> MsSqlDataBinderAttribute
Parameters
fieldName
Type: SystemString
Field name of MS-SQL Server table or procedure execution result
  See Also
Reference
MsSqlDataBinderAttribute Class
TaeM.Framework.Data.MsSql Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlDataBinderAttribute Properties

The MsSqlDataBinderAttribute type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | FieldName Property - Field name of MS-SQL Server table or procedure execution result. Therefore, the data of the field specified here is bound to a property or a variable of a specific class specified as an Attribute.
Top
See Also

Reference

MsSqlDataBinderAttribute Class
TaeM.Framework.Data.MsSql Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MsSqlDataBinderAttribute.FieldName Property

MsSqlDataBinderAttributeFieldName Property

FieldName Property - Field name of MS-SQL Server table or procedure execution result. Therefore, the data of the field specified here is bound to a property or a variable of a specific class specified as an Attribute.

Namespace: TaeM.Framework.Data.MsSql
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}
member FieldName : string with get, set

Property Value
Type: String
  See Also
Reference
MsSqlDataBinderAttribute Class
TaeM.Framework.Data.MsSql Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MsSqlDataBinderAttribute Methods

The MsSqlDataBinderAttribute type exposes the following members.

Methods
 | Name | Description
Public method | CreateDataBinderAttribute | CreateDataBinderAttribute method - Implements data binder attribute string for setting data from MS-SQL Server
Top
See Also

Reference

MsSqlDataBinderAttribute Class
TaeM.Framework.Data.MsSql Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MsSqlDataBinderAttribute.CreateDataBinderAttribute Method

MsSqlDataBinderAttributeCreateDataBinderAttribute Method

CreateDataBinderAttribute method - Implements data binder attribute string for setting data from MS-SQL Server

Namespace: TaeM.Framework.Data.MsSql
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public Object CreateDataBinderAttribute(
    MemberInfo member
)
Public Function CreateDataBinderAttribute (
    member As MemberInfo
) As Object
public:
virtual Object^ CreateDataBinderAttribute(
    MemberInfo^ member
) sealed
abstract CreateDataBinderAttribute :
        member : MemberInfo -> Object
override CreateDataBinderAttribute :
        member : MemberInfo -> Object
Parameters
member
Type: System.ReflectionMemberInfo
an object of MemberInfo(Field or Property)
Return Value
Type: Object
an object of member that has IDataBinder attribute.
  See Also
Reference
MsSqlDataBinderAttribute Class
TaeM.Framework.Data.MsSql Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


TaeM.Framework.Data.MySql Namespace

This namespace contains some classes for data binding MySQL Database Server's data to user defined entity class.
Classes
 | Class | Description
Public class | MySqlDataBinderAttribute | MySqlDataBinderAttribute class - Implements data binder attribute in entity class for MySQL DB

Send comments on this topic to mail@taemcorp.com


MySqlDataBinderAttribute Class

MySqlDataBinderAttribute class - Implements data binder attribute in entity class for MySQL DB
Inheritance Hierarchy
SystemObject
SystemAttribute
TaeM.Framework.Data.MySqlMySqlDataBinderAttribute

Namespace: TaeM.Framework.Data.MySql
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
[AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)]
public class MySqlDataBinderAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field)>
Public Class MySqlDataBinderAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Property|AttributeTargets::Field)]
public ref class MySqlDataBinderAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)>]
type MySqlDataBinderAttribute =
    class
        inherit Attribute
    end
The MySqlDataBinderAttribute type exposes the following members.
  Constructors
 | Name | Description
Public method | MySqlDataBinderAttribute | Constructor of MySqlDataBinderAttribute
Top
  Properties
 | Name | Description
Public property | FieldName | FieldName Property - Field name of MySQL Server table or procedure execution result. Therefore, the data of the field specified here is bound to a property or a variable of a specific class specified as an Attribute.
Top
  Methods
 | Name | Description
Public method | CreateDataBinderAttribute | CreateDataBinderAttribute method - Implements data binder attribute string for setting data from MySQL DB
Top
  See Also
Reference
TaeM.Framework.Data.MySql Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlDataBinderAttribute Constructor

Constructor of MySqlDataBinderAttribute

Namespace: TaeM.Framework.Data.MySql
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public MySqlDataBinderAttribute(
    string fieldName
)
Public Sub New (
    fieldName As String
)
public:
MySqlDataBinderAttribute(
    String^ fieldName
)
new :
        fieldName : string -> MySqlDataBinderAttribute
Parameters
fieldName
Type: SystemString
Field name of MySQL DB table or procedure execution result
  See Also
Reference
MySqlDataBinderAttribute Class
TaeM.Framework.Data.MySql Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlDataBinderAttribute Properties

The MySqlDataBinderAttribute type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | FieldName Property - Field name of MySQL Server table or procedure execution result. Therefore, the data of the field specified here is bound to a property or a variable of a specific class specified as an Attribute.
Top
See Also

Reference

MySqlDataBinderAttribute Class
TaeM.Framework.Data.MySql Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MySqlDataBinderAttribute.FieldName Property

MySqlDataBinderAttributeFieldName Property

FieldName Property - Field name of MySQL Server table or procedure execution result. Therefore, the data of the field specified here is bound to a property or a variable of a specific class specified as an Attribute.

Namespace: TaeM.Framework.Data.MySql
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}
member FieldName : string with get, set

Property Value
Type: String
  See Also
Reference
MySqlDataBinderAttribute Class
TaeM.Framework.Data.MySql Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com


MySqlDataBinderAttribute Methods

The MySqlDataBinderAttribute type exposes the following members.

Methods
 | Name | Description
Public method | CreateDataBinderAttribute | CreateDataBinderAttribute method - Implements data binder attribute string for setting data from MySQL DB
Top
See Also

Reference

MySqlDataBinderAttribute Class
TaeM.Framework.Data.MySql Namespace

Copyright © 2019 TaeM corp. All rights reserved.

Send comments on this topic to mail@taemcorp.com


MySqlDataBinderAttribute.CreateDataBinderAttribute Method

MySqlDataBinderAttributeCreateDataBinderAttribute Method

CreateDataBinderAttribute method - Implements data binder attribute string for setting data from MySQL DB

Namespace: TaeM.Framework.Data.MySql
Assembly: TaeM.Framework.Net20 (in TaeM.Framework.Net20.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
F#
ASP.NET
Copy
public Object CreateDataBinderAttribute(
    MemberInfo member
)
Public Function CreateDataBinderAttribute (
    member As MemberInfo
) As Object
public:
virtual Object^ CreateDataBinderAttribute(
    MemberInfo^ member
) sealed
abstract CreateDataBinderAttribute :
        member : MemberInfo -> Object
override CreateDataBinderAttribute :
        member : MemberInfo -> Object
Parameters
member
Type: System.ReflectionMemberInfo
an object of MemberInfo(Field or Property)
Return Value
Type: Object
an object of member that has IDataBinder attribute.
  See Also
Reference
MySqlDataBinderAttribute Class
TaeM.Framework.Data.MySql Namespace
Copyright © 2019 TaeM corp. All rights reserved.
Send comments on this topic to
        mail@taemcorp.com